Author Topic: 9-3 Engine cutting out when trying to reverse  (Read 125 times)

StanleyB

  • Linear
  • *
  • Posts: 78
  • Number of thanks: 1
    • View Profile
9-3 Engine cutting out when trying to reverse
« on: 31 August 2017, 07:49:54 PM »
I have had this problem of late that when the engine is hot it cuts out when I try to reverse. Since it only happens when reversing I am wondering if it could be the DIC or the oxygen sensor. I am however inclined to discount the DIC.

Audax

  • SST paid up supporter
  • Wide open throttle
  • *
  • Posts: 2798
  • Number of thanks: 185
    • View Profile
Re: 9-3 Engine cutting out when trying to reverse
« Reply #1 on: 01 September 2017, 09:23:49 AM »
Auto or manual?

Also, does it cut out when you put it in reverse gear or does it cut out when you take your foot off the clutch or brake and start to reverse or only when it's actually moving backwards?


StanleyB

  • Linear
  • *
  • Posts: 78
  • Number of thanks: 1
    • View Profile
Re: 9-3 Engine cutting out when trying to reverse
« Reply #2 on: 01 September 2017, 10:29:13 AM »
It's a manual. Cuts out when I lift my foot off the clutch.

Audax

  • SST paid up supporter
  • Wide open throttle
  • *
  • Posts: 2798
  • Number of thanks: 185
    • View Profile
Re: 9-3 Engine cutting out when trying to reverse
« Reply #3 on: 01 September 2017, 08:22:27 PM »
If you give it more revs while selecting reverse and lifting off the clutch does it still do it?

It sounds like a vacuum leak or similar, I'm sure I've seen this fault before but can't think what it was.

One further thought, do you have your foot on the brake just before doing this? If so try stopping on level ground and lift your foot off the brake and select reverse and see what it does.

StanleyB

  • Linear
  • *
  • Posts: 78
  • Number of thanks: 1
    • View Profile
Re: 9-3 Engine cutting out when trying to reverse
« Reply #4 on: 04 September 2017, 09:32:35 PM »
Well after spending some time with a mate of mine in trying to find any dodgy hose, he detected a puncture hole in the intercooler. Based on some of the fault symptoms that I experienced, it looked like the likely culprit. So I had that replaced today. I took the car for an hour run on the A1 and all seems well so far. I'll know for sure when I drive it down to Wales in two weeks.

Audax

  • SST paid up supporter
  • Wide open throttle
  • *
  • Posts: 2798
  • Number of thanks: 185
    • View Profile
Re: 9-3 Engine cutting out when trying to reverse
« Reply #5 on: 05 September 2017, 07:37:27 AM »
That sounds familiar, I now recall a car with similar symptoms where it would stall when reversing and eventually we found a small split in the flexi-hose to the intercooler, no CEL showing and it wasn't that down on performance under boost when going forwards.