Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - fka

Pages: [1] 2 3 ... 43
1
Only had an ad on UKS and it was picked up within a day by a reasonably well known dealer. Deposit paid last week, collected today.
The v10 was very tempting but I wanted something newer. Started a new job in May and I have no time or will at the moment to spend fixing my daily. Ignition switch was on the way out on the 9-5 and that was the final straw.
This one shifts 0-60 (to 62 in 6.1 seconds on paper). Doesn't come close the the 9-5 midrange at motorway speeds though. But that's not the point, it wafts perfectly well.
And thanks, I'm sure to pop in from time to time.

2
I sold it!
Brought on by a number of factors but primarily because I wanted a better tow car, I've bought a VW toerag. After a lot of looking I finally found this one within my budget, which has a few options I really wanted; air suspension, factory towbar, sunroof and ergocomfort seats. There's only two or three options it doesn't have. I'm fairly chuffed with it. First diesel I've owned since my 1.5L AX back in 1999.

I'm sure I'll still pop my head round the door once in a while. But a huge thankyou to everyone for your help and advice. And when money allows, I'm planning to pick up a C900. Not sure when that will be but I live in hope  ;D


3
and in the middle of it all you take a call from me about how to drive a Tech2  ;D

4
Classic Saab 9-5 (MY 1998-2010) / Re: Starting issue - ignition switch
« on: 16 October 2020, 10:20:54 PM »
Think I must have pulled the wrong part number off the EPC. It's 4943692 which is 160 on Bill's website.
If it comes to it, I can swallow that price..

5
Classic Saab 9-5 (MY 1998-2010) / Re: Starting issue - ignition switch
« on: 16 October 2020, 09:58:54 PM »
I didn't dismantle the whole cylinder like this guy does. I'm guessing I have a lot of muck still inside the barrel..

https://www.youtube.com/watch?v=KrejkaVKKvk

6
Classic Saab 9-5 (MY 1998-2010) / Re: Starting issue - ignition switch
« on: 16 October 2020, 09:32:53 PM »
I phoned Bill today and the price of a new switch is slightly eye watering. So I'm either looking at trying to repair mine or try and find a decent salvaged one. Regardless I'll be living with it unit it becomes unworkable. It's a huge job to remove it.

Once I'd cleaned the cylinder out it ran very rough. Possibly still some dirt in there but it wasn't for shifting. I had to work the key in it with lithium until it ran smooth. All I can say is it currently working nicely and pops back up as it should when the key comes out. I'm sure a graphite lube would have been preferable but I didn't have nay to hand.

7
Classic Saab 9-5 (MY 1998-2010) / Starting issue - ignition switch
« on: 16 October 2020, 08:29:12 PM »
It's turning into a bit of an "oh what next!' few months..

Once I mentioned this to the Mrs it seems it's been happening quite regularly since I took the cylinder out and cleaned it. But I think it has happened occasionally prior to that.
Turn the key to on and all seems normal, turn to start and the engine doesn't turn over, no sign of any life. Hold the key in start and it will eventually turn over and start normally.

I'm assuming it's the ignition switch acting up rather than the cylinder but could the action of the cylinder cause the switch not to function in this way?
I lubed the cylinder with white lithium grease spray, which should have quickly solidified. So I don't believe that would have contaminated the switch.

Also is there any way of cleaning the switch without removing it and taking it apart?
Especially on the manual, removal of the switch looks like a total pain in the ar5e..

8

Glad the small jobs are working out ok FKA, even though they seem to be accumulating. Split the case and test the battery voltage against my thread. That might indicate a battery or capacitor problem.


I'm hopefully coming to the end of a run - but never say never!

I went to Joe's yesterday and we had a go with the TechII to set the alarm to use the horn instead of the siren. It seems this is not actually possible despite a number of people on different forums saying it is. Quick call to Phoenix (Mark E) and he checked his Edna and found the alarm had just been uninstalled/removed so he talked me through how to do it. I owe you a few beers Mark! And Joe frankly, who just left me to tinker with the TechII FOC!
Think I'd quite like a TechII of my own to play with..

Today I removed the brake booster vac hose fitting from the charge air pipe and fit a new one. The last leak I could find in the system plugged!
Was a bit of a pain. Had to remove the pipe and use a bolt, socket and g-clamp to press it out.


9
Fit a new thermostat today. I couldn't, or should say, didn't want to force the hose off the housing. Clamp came off easily enough but the hose was solid on the housing. Tried heating it up with a heat gun but it wasn't for shifting. I just took the housing off with the hose still attached, no big deal.
Cleaned the mating surfaces as best I could with a razor blade and brake cleaner.
I've ordered some non-acidic vaseline but it didn't arrive in time so I just used regular stuff. Not sure if this will prove to be an issue down the road.
The coolant that came out was fairly rusty looking. I didn't do a flush so I may change it again in spring.
Also the green drain plug on the radiator came out very easily and when I turned it back it, it didn't seem to click closed (if that makes sense). However it's not leaking..
Engine came up to temp fine and the fans kicked in at 100c. Seems to hold around 93 to 98C at idle.

Also moved the ground on the inlet manifold again. I'd placed it between the black powder coated bracket and the manifold but I noticed the other day the thread had stripped and I was never really happy with it here. The pre-drilled and unused hole it's now in was untapped but I realised the bolts are self tapping so it's locked down well.

I've also noticed I have the return of a misfire on light throttle when cold. Completely goes away once up to temp.
I thought I'd solved that when I re-terminated the grounds on the thermostat and inlet manifold. It seems not! Only other thing I did at the time that seems to have resolved it was run some injector cleaner through it. So I've ordered some Forte..



10
That escalated quickly. Bloody thing wouldn't stop going off!
My ears are bleeding and my tinnitus has just taken a huge leap forward..

It's off now. Question is, is it worth repairing or do I just get it TechII'd out and use the horn instead?


11
Bugger!

Well my alarm has been going of repeatedly this afternoon, so I'll be adding disconnecting the siren box this weekend too!

12
Classic Saab 9-5 (MY 1998-2010) / Re: CPS change
« on: 07 October 2020, 03:43:59 PM »
I understand wine is good for a sore throat..
Hope you're feeling better soon!

13
Thanks for the warning. Hopefully that one shouldn't give me a problem, I've had the earths off last year when I re-terminated them.

14
My headlights are always on (/daylight running). I've noticed a few times over the last week or so that they're staying on when I take the key out of the ignition. Put the key back in, turn it and remove it again and they go off.

Took the cylinder out today and it was feeling very rough. Removed the white plastic cap, spring and washer. Gave it a good blast with brake parts cleaner and a fair amount of gritty stuff came out. Muck or warn metal from the cylinder, I'm not sure. Lubed liberally with white lithium and worked the key for a while until it ran smooth. Reassembled and now it's popping up like never before when the key comes out. Not a bad result for 20 mins work.

I have everything to replace the thermostat but I'm saving that one for the weekend.

15
I couldn't have told you the name of the map but yes that what I was saying. But according to Karl's posts in the thread you linked, the warm-up map is ramped based on Teng - up to 80c - and the number of combustions from start. Number of combustions from startup outweighs Teng - thus after x number of combustions it will run on the normal running fuel map regardless of Teng. Ergo fuel consumption would only be noticeably higher [with a duff thermostat] if you're regularly doing short start/stop trips, sort enough that you don't exceed the 'x' number of combustions and thus stay within the warm-up map.

Pages: [1] 2 3 ... 43