Author Topic: Temp sensor and blower heat issues  (Read 336 times)

Steve McF

  • Twin Turbo
  • ***
  • Posts: 875
  • Number of thanks: 7
  • 9-5 2.0LPT.....as was, and now 9-3ss 2.0T Aero :)
    • View Profile
Temp sensor and blower heat issues
« on: 11 February 2019, 08:58:45 PM »
My outside temp display has been playing up. Well not the display, but the temp seems to be less than acurate,  showing 60 deg C. However, when I got home tonight, it had ceased to register any temperature at all!!!

Possibly related, or maybe not, I cannot get hot air out of the blowers unless I set the temp to "Hi". If I select 27 deg C or less, all I get is cold air.

What is going on there then?

« Last Edit: 11 February 2019, 09:00:59 PM by Steve McF »

sgould

  • Aerobic
  • SST paid up supporter
  • Wide open throttle
  • *
  • Posts: 4151
  • Number of thanks: 310
  • 2006 9-5 Aero estate - Hirsched.
    • View Profile
    • Christine Bennett - soprano
Re: Temp sensor and blower heat issues
« Reply #1 on: 11 February 2019, 09:25:05 PM »
Has the sensor fallen out of the hole or become disconnected?

The  sensor is right in he middle of the lower grille.  It can fall out of the clip, but should still give a reading.  If no reading, it's probably died, or maybe the cable has detached.  It runs across to join the loom behind the LH foglamp.
Help support SaabTechTalk by making a Lump Sum donation or by opening a subscription. 
Options available are in your Profile/Actions.

Audax

  • SST paid up supporter
  • Wide open throttle
  • *
  • Posts: 3079
  • Number of thanks: 201
    • View Profile
Re: Temp sensor and blower heat issues
« Reply #2 on: 11 February 2019, 10:00:23 PM »
The sensors are remarkably bad quality, I think the exact same genuine part can be had from Vauxhall for less than Saab.

aerojon

  • LPT
  • **
  • Posts: 227
  • Number of thanks: 20
    • View Profile
Re: Temp sensor and blower heat issues
« Reply #3 on: 12 February 2019, 02:26:39 AM »
the sensor is tied into the ac system,a new one will cure the problem if everything else checks out..

my sensor is the original,still ok..

Steve McF

  • Twin Turbo
  • ***
  • Posts: 875
  • Number of thanks: 7
  • 9-5 2.0LPT.....as was, and now 9-3ss 2.0T Aero :)
    • View Profile
Re: Temp sensor and blower heat issues
« Reply #4 on: 12 February 2019, 01:03:19 PM »
Is it easy to access?

I seem to recall on our Zafira I could reach down inside the engine bay. Not sure the 9-3 engine bay is quite so spacious?
« Last Edit: 13 February 2019, 12:50:20 PM by Steve McF »

aerojon

  • LPT
  • **
  • Posts: 227
  • Number of thanks: 20
    • View Profile
Re: Temp sensor and blower heat issues
« Reply #5 on: 12 February 2019, 06:12:56 PM »
need to access from underneath,need to remove the tray or it can be changed thru the slats in the bumper(seen it done)

see pic for location..

Steve McF

  • Twin Turbo
  • ***
  • Posts: 875
  • Number of thanks: 7
  • 9-5 2.0LPT.....as was, and now 9-3ss 2.0T Aero :)
    • View Profile
Re: Temp sensor and blower heat issues
« Reply #6 on: 13 February 2019, 12:52:04 PM »
Yes that looks like it is in the same place as the Zafira. From memory, it wasn't that expensive a part? Does anyone know the part number, and whether I can just order it from a Vauxhall dealer?

sgould

  • Aerobic
  • SST paid up supporter
  • Wide open throttle
  • *
  • Posts: 4151
  • Number of thanks: 310
  • 2006 9-5 Aero estate - Hirsched.
    • View Profile
    • Christine Bennett - soprano
Re: Temp sensor and blower heat issues
« Reply #7 on: 13 February 2019, 02:28:19 PM »
9152245

That's a GM part number, so if fitted to a Vauxhall, it will have the same number.
Help support SaabTechTalk by making a Lump Sum donation or by opening a subscription. 
Options available are in your Profile/Actions.

Norfolk Jim

  • SST paid up supporter
  • Viggen
  • *
  • Posts: 1762
  • Number of thanks: 27
  • :) I said Twin Turbo mate - Yes 2 on em
    • View Profile
Re: Temp sensor and blower heat issues
« Reply #8 on: 19 February 2019, 10:17:25 AM »
I had these issues last year with my 58 Aero TTiD. Some days it would say 5 deg when it was 25 deg and then the reverse. I managed to get lower grille off and found connections a little messy. Cleaned the sensor and clipped it back in - ok for a while then I noticed it hanging there one morning and no reading. A/c all over the place. Blowing hot air when mid 20's outside and not even cold when on low setting.

Ordered a new one online and made sure very carefully fitted and all was fine for 3 weeks then it went haywire again. I found there was a break in the wiring loom which I managed a temp repair and then sold the car. The parts guy I knew at main dealers said it would be a new loom (which also covered the foglights) but these were on back order with no idea of when one would be available. He suggested an auto electrician insert new section of wires across the front; cheaper and quicker than waiting.
Who said diesels dead - mine goes allriot

Steve McF

  • Twin Turbo
  • ***
  • Posts: 875
  • Number of thanks: 7
  • 9-5 2.0LPT.....as was, and now 9-3ss 2.0T Aero :)
    • View Profile
Re: Temp sensor and blower heat issues
« Reply #9 on: 21 February 2019, 04:08:25 PM »
Well this morning I was surprised to feel heat coming from the vents when the climate was set to 25 deg C. I toggled through the SiD to find the outside temp display working again and showing 10 degrees!!!

Don't you just love intermittent faults!!!

When I put the car in to have the chain tensioners looked at I might just get them to look at some of this silly sort of stuff as well.!!!